安装ia32-libs出现依赖关系的纠结问题处理方案

今天在终端下卸载bluefish结果提示有依赖关系不能卸载,然后提示使用“sudo apt-get -f  install”然后还不成我就果断用“sudo apt-get autoremove”把需要卸载的都卸载掉了,其中貌似还卸载了个什么忘记了!最新工作忙脑细胞不够用的说!

然后我们说重点,整理玩bluefish后发现我的wps办公软件不能正常使用了!虽然还在但是感觉缺少ia32-libs依赖,所以想安装上,结果提示如下图:

forum.php可是,因为第一次遇到这样的情况还以为是因为自己升级后吧对应的什么组建什么的升级后不支持了?然后没办法到wps社区求助,结果到我写这篇文档的时间还是没有得到任何回复,看来有写事情需要靠的就是自己哦!

wps[咨询求助]帖子地址:点击传送

然后也不能就这么放弃吧?百度不成我就谷歌了一下,结果发现在ubuntu社区中有以为朋友提出是不是因为“软件源”的问题?更换一个有效的软件源后在update一下然后安装看看,好吧,有方法处理总比没事情做,没有任何结果的好吧?然后我就尝试了更换一下软件源,如下图

012

013把之前选择的163的源更换成了主服务器,然后吧“不支持的更新”前面的对好去掉了!然后update的一下,然后在输入“sudo apt-get install ia32-libs”然后世界有变的美丽了,如图:

011ok,这篇博文还是因为自己遇到过,所以写下来,希望能对看到这篇博文你有所帮助:)

崔哲博客本文短连接地址 : https://xn--xwr12q.xn--fiqs8s/RmmEA
点赞
  1. ixwebhosting说道:

    强大,好佩服的

    1. 崔哲说道:

      还是要学习的呢……

  2. 豆腐面说道:

    一看就是玩linux的高手啊~

    1. 崔哲说道:

      不是呢,还是菜鸟呢!

  3. 常阳时光说道:

    Linux,折腾不起啊~